Cluster B Mail Delays
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 13, 2018 - 15:24 UTC
Identified
-
We experienced inbound mail delivery issues with our Cluster B for a small group of users. We have since corrected the issue and are working through the backlog of messages.

Some messages sent may still be delayed as we work through our queue.
Posted 2 months ago. Jul 13, 2018 - 15:09 UTC
This incident affected: Hosted Email (Cluster B).