Cluster B
Incident Report for OpenSRS
Resolved
We've received additional reports that certain ISPs could not connect to cluster B.

As of the time of this update, we've resolved both the connectivity issue as well as the webmail portal issue.
Posted 15 days ago. Nov 01, 2018 - 15:51 UTC
Identified
We are currently receiving reports of users experiencing issues logging into webmail for cluster B.

All other cluster B services regarding sending and receiving should still be operational.

Our engineers are aware of the issue and proactively working on a solution
Posted 16 days ago. Nov 01, 2018 - 14:34 UTC
This incident affected: Hosted Email (Webmail).