GeoTrust DV Approval Email Selection
Incident Report for OpenSRS
Resolved
GeoTrust confirmed they have resolved the DV Approval Email Selection problem so all future orders will process without issues. They indicated the approval emails for the orders which were impacted were also resent, however, if they have still not been received for those orders, please contact us to resend them manually for you.
Posted 7 days ago. Dec 04, 2017 - 08:08 UTC
Investigating
There appears to be an issue currently with selecting the approver email address for GeoTrust SSL certificate orders, as the only option is for DV Email validation to use is support@geotrust.com. As a result, no other email address can be selected so such orders cannot currently be approved. We have reached out to GeoTrust, and it is currently being investigated by their Engineering team. We will provide an update as soon as possible.
Posted 7 days ago. Dec 04, 2017 - 04:29 UTC
This incident affected: SSL.