Cluster B inbound mail delays
Incident Report for OpenSRS
Resolved
This issue is now resolved and all users on Cluster B should no longer experience any inbound mail delays.
Posted Dec 05, 2019 - 21:43 UTC
Monitoring
We have implemented a fix that has fully restored email services for users on Cluster B. The root cause was related to maintenance work and due to a missing configuration directory. That resulted in inbound mail being delayed.

We will monitor the situation for the time being to ensure all services are restored.
Posted Dec 05, 2019 - 20:47 UTC
Investigating
We are currently experiencing an issue where inbound mail for users on Cluster B may be delayed. We will continue investigating and provide updates as soon as we can
Posted Dec 05, 2019 - 19:03 UTC
This incident affected: Hosted Email (Cluster B).