Reseller Chat Support
Incident Report for OpenSRS
Resolved
-
We are happy to report the problems related to our support chat have now been resolved.
Posted Nov 16, 2018 - 00:35 UTC
Investigating
-
We are experiencing issues with our Support chat at this time. When Initiating a new chat, the chat may freeze and you may not be able to further type additional information.
As an alternative, please use our phone and or email support at opensrs.com/contact.

We will keep you posted with additional information.
Posted Nov 15, 2018 - 23:28 UTC