.MS Registry
Incident Report for OpenSRS
Resolved
There are no other reports of problems. This has since been resolved.
Posted 2 months ago. Oct 04, 2018 - 01:46 UTC
Monitoring
.ms domain orders seem to be behaving as expected.

Yet there's no official word from the registry as of yet. We will mark the issue as resolved when the registry confirms the connection issues have stopped.
Posted 2 months ago. Oct 01, 2018 - 15:27 UTC
Investigating
We are currently experiencing issues connecting to the .MS domain registry. This would impact the ordering of new domains and the management of existing domains. The issues appear to be at the registry itself and our Operations team has already reached out to them. We will provide an update once the connection is restored.
Posted 2 months ago. Sep 30, 2018 - 14:59 UTC
This incident affected: Domain Services (Other ccTLDs).