Email - Cluster A & B
Incident Report for OpenSRS
Postmortem

On February 05, 2019 , at 17:10 ET. Tucows’ hosted email platform experienced service degradation , email delivery delays, impacting inbound and outbound traffic in prod A and B.

The service degradation was caused by a security change that was deployed by error outside of the scheduled maintenance window.

At 17: 48 The Operations Team completed the roll back to restore services and stabilize the load in the email environment.
Tucows is to revise and improve the change management process to prevent future errors.

Posted 5 months ago. Feb 13, 2019 - 21:20 UTC

Resolved
This incident has been resolved.
Posted 5 months ago. Feb 05, 2019 - 22:53 UTC
Identified
Users may experience issues receiving email across both clusters.

The issue has been identified and we're actively working on a fix.

Next Update: 23:00 UTC
Posted 5 months ago. Feb 05, 2019 - 22:30 UTC
This incident affected: Hosted Email (Cluster A, Cluster B, Webmail).