Webmail Degraded Performance
Incident Report for OpenSRS
Resolved
The degraded performance we were experiencing on Cluster B webmail is now resolved.
Posted 11 days ago. Feb 08, 2018 - 18:48 UTC
Identified
Our operations team is investigating Cluster B webmail performance issues at this time.
Posted 11 days ago. Feb 08, 2018 - 18:33 UTC
This incident affected: Hosted Email (Webmail).