Registrar Mail
Incident Report for OpenSRS
Resolved
Our operations team was able to address the issue, and our mail queues have cleared up now.
Posted 10 days ago. Nov 07, 2018 - 14:39 UTC
Investigating
We are experiencing message sending delays on the registrar mail system used to relay registrant verification and other system messages. Some messages sent may be delayed as we work through resolving the issue.
Posted 10 days ago. Nov 07, 2018 - 11:45 UTC
This incident affected: System Messaging.