Domain services issue
Incident Report for OpenSRS
Postmortem

Incident Date: February 11, 2020
Incident Number: PR-855

On February 11, 2020 at 11:14 AM ET, We experienced issues with Tucows’ Domains platform impacting Identity services. The Operations team was engaged and started investigating the issue.

At 11:24 AM ET, Operations identified that root cause to be related to an upgrade performed on Identity services causing it to disconnect with the Authentication services running on older SSL ciphers.

At 11:34 AM ET, the Operations team upgraded the SSL ciphers on Authentication service, and the connectivity between Identity and Authentication services were restored successfully.

Tucows to audit and upgrade the SSL ciphers on Authentication services.

Tucows to review the upgrade process and ensure sanity checks are performed for Authentication services prior to any upgrades on the Identity services.

Thank you,

Tucows Engineering Team

Posted Feb 28, 2020 - 18:09 UTC

Resolved
This issue is now resolved and users should no longer experience those domain problems
Posted Feb 11, 2020 - 18:05 UTC
Monitoring
A fix has been implemented to correct the domain services issues we were experiencing and users should no longer have those problems.

We will continue to monitor the situation for the time being
Posted Feb 11, 2020 - 16:55 UTC
Investigating
We are currently experiencing an issue with our domains service which can result in users having trouble making contact changes on their domains as well as processing new domain orders.

Updates will be provided when available

Next update at 5:35 PM UTC
Posted Feb 11, 2020 - 16:37 UTC
This incident affected: Domain Services (Core gTLDs, Core ccTLDs, Other gTLDs).