New GDPR Transfer Policy
Incident Report for OpenSRS
Resolved
Transfer-in requests are working as intended. Transfer authorization emails are being dispatched to the transfer contact that was specified in the submission.
Posted May 26, 2018 - 00:50 UTC
Identified
The new GDPR transfer policy has not been rolled out yet. Our marketing team will send out an announcement once the implementation is complete.
Posted May 25, 2018 - 15:29 UTC