.CA Registry Connections
Incident Report for OpenSRS
Resolved
The issue is now resolved and services are back to normal.
Posted 4 months ago. Jul 04, 2019 - 15:55 UTC
Investigating
We are currently experiencing connection issues with the .CA registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .CA domains. Existing domains will continue to resolve normally.
Posted 4 months ago. Jul 04, 2019 - 15:38 UTC
This incident affected: Domain Services (Core ccTLDs).