Sectigo Vendor Connections
Incident Report for OpenSRS
Resolved
Our vendor was able to address the issue on their end. Service has been restored.
Posted 5 days ago. Apr 16, 2019 - 11:06 UTC
Investigating
We are currently experiencing connection issues with Sectigo Certificate Authority. You may experience issues with ordering/managing Sectigo SSL products. Our operations team is investigating the issue.
Posted 5 days ago. Apr 16, 2019 - 10:08 UTC
This incident affected: SSL.