Comodo Maintenance
Incident Report for OpenSRS
Resolved
The ongoing Comodo maintenance has now completed
Posted 6 days ago. Apr 14, 2018 - 23:12 UTC
Monitoring
Comodo will be performing server maintenance. During this maintenance period, we will not be able to process any updates or transactions. If you receive an error when processing a request please try again in an hour. If you continue to experience errors please contact support.
Posted 6 days ago. Apr 14, 2018 - 23:09 UTC
This incident affected: SSL.