Cluster B Webmail Connectivity
Incident Report for OpenSRS
Resolved
The webmail connectivity issue on Cluster B has been resolved. We apologise for the inconvenience.
Posted 12 months ago. May 07, 2017 - 23:56 UTC
Investigating
Our operations team is currently investigating webmail connectivity issues on Cluster B. We will update you as soon as we have more information.
Posted 12 months ago. May 07, 2017 - 17:25 UTC
This incident affected: Hosted Email (Cluster B).