.SR Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that our connection has been restored to the .SR Registry. Any previous orders may now be processed and or orders that were in the draft state.
Posted 17 days ago. Aug 08, 2019 - 12:39 UTC
Identified
Our status still remains the same, Our connection issues still persist and we are reaching out to the registry for further details.

This will affect registrations, renewals, and management of .SR domains
Posted 18 days ago. Aug 07, 2019 - 19:18 UTC
Investigating
We are currently experiencing connection issues with the .SR registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .SR domains. Existing domains will continue to resolve normally.
Posted 19 days ago. Aug 06, 2019 - 17:16 UTC
This incident affected: Domain Services (Other ccTLDs).