Webmail Performance
Incident Report for OpenSRS
Resolved
Webmail performance has now returned to normal. Thank you for your patience in this matter.
Posted Jan 17, 2018 - 17:16 UTC
Investigating
Our operations team is investigating reports of degraded webmail performance impacting some mailboxes. We will update this status as soon as there is further information available.
Posted Jan 17, 2018 - 17:03 UTC
This incident affected: Hosted Email (Webmail).