Payment Gateway Issue
Incident Report for OpenSRS
Resolved
The issue we were experiencing with our payment gateway has been resolved. Thank you for your patience and we apologise for the inconvenience.
Posted 4 months ago. May 18, 2017 - 13:59 UTC
Identified
Resellers may experience issues adding funds to their account. Our operations team is actively working on resolving the problem.

An update will follow as new information becomes available.
Posted 4 months ago. May 18, 2017 - 13:45 UTC
This incident affected: Control Panels (Reseller Control Panel).