Visa transactions for European Customers
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 01, 2018 - 22:24 UTC
Monitoring
-
We may be currently experiencing payment declines and failures for European customers paying with VISA due to an internal issue at Visa affecting merchants worldwide.

We will continue to follow the Visa developments closely.

Next Update: Sunday 21:00 UTC
Posted 2 months ago. Jun 01, 2018 - 17:54 UTC