.KIWI Registry Connections
Incident Report for OpenSRS
Resolved
We are pleased to note that all connections for .kiwi have restored.
Posted Jul 18, 2019 - 03:14 UTC
Investigating
We are currently experiencing connection issues with the .KIWI registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .KIWI domains. Existing domains will continue to resolve normally.
Posted Jul 18, 2019 - 02:33 UTC
This incident affected: Domain Services (Other gTLDs).