Email Domain Creation
Incident Report for OpenSRS
Resolved
Email domain creation on Cluster B is now functioning as expected. Thank you for your patience.
Posted 12 months ago. Dec 29, 2017 - 17:52 UTC
Identified
We are currently experiencing issues with the creation of new email domains on Cluster B. Our operations team is investigating the incident.
Posted 12 months ago. Dec 29, 2017 - 17:34 UTC
This incident affected: Hosted Email (Cluster B).