API Access + WHOIS Service
Incident Report for OpenSRS
Postmortem

On March 06, 2019, at 1:17 PM ET. Tucows’ Domains platform experienced service interruption. The incident impacted OSRS, HRS and Hover domains lookup and registrations.
The cause of the incident under investigation and yet be determined by our Senior Engineers.

At 3:50 PM ET The Operations Team restored services after completing a rolling restart on the affected nodes in production.

Tucows is to improve monitoring to detect unresponsive running services. Further preventive measures to be implemented after completing root cause analysis.

Posted 4 days ago. Mar 14, 2019 - 12:53 UTC

Resolved
This incident has been resolved.
Posted 12 days ago. Mar 06, 2019 - 21:00 UTC
Monitoring
Our team has identified the issue and deployed a solution. API exchanges and WHOIS should now be operational. We will continue monitoring the situation.

Next Update 21:00UTC
Posted 12 days ago. Mar 06, 2019 - 20:22 UTC
Update
We are continuing to investigate this issue.
Posted 12 days ago. Mar 06, 2019 - 19:43 UTC
Investigating
We are currently experiencing issues regarding:

our customer's capacity of exchanging API requests and responses,
our whois service not responding to queries,

Our team is investigating.

Next Update: 21:00UTC
Posted 12 days ago. Mar 06, 2019 - 19:37 UTC
This incident affected: APIs (OpenSRS API, OpenHRS API, Email API) and Domain Services (WHOIS).