Trustwave - Service outage
Incident Report for OpenSRS
Resolved
We are happy to report that our connections with Trustwave are now operational. Thank you for your patience in this matter.
Posted May 22, 2018 - 16:53 UTC
Investigating
We are experiencing an outage with the certificate authority Trustwave. Orders may be interrupted during this time. We will continue to provide updates on this as it progresses.
Posted May 22, 2018 - 15:34 UTC
This incident affected: SSL.