Sectigo (Comodo) SSL Certificates
Incident Report for OpenSRS
Resolved
We're happy to report our connection to Sectigo (Comodo) has now been fully restored so there are no further issues.
Posted 6 months ago. Dec 16, 2018 - 03:38 UTC
Investigating
Sectigo (Comodo) underwent scheduled maintenance earlier today, and approximately 1-hour after it completed (9pm ET) we starting encountering connection issues to them on our end . For the time being, resellers will be unable to order Sectigo (Comodo) SSL certificates, or edit existing orders with them. We've reached out to them and hope to provide an update on this matter soon.
Posted 6 months ago. Dec 16, 2018 - 03:05 UTC
This incident affected: SSL.