Registrant Verification
Incident Report for OpenSRS
Resolved
Our Development team has now resolved this issue where there should now no longer be any issues with end users completing the Registrant Verification process. Thank you for your patience.
Posted 5 months ago. Apr 12, 2018 - 03:24 UTC
Update
Our development team is continuing to work on resolving this matter as soon as possible.
Posted 5 months ago. Apr 11, 2018 - 17:37 UTC
Identified
Some users may experience an "unknown error" when attempting to complete the registrant verification process. Our development team is working to correct this issue as quickly as possible.
Posted 5 months ago. Apr 11, 2018 - 14:29 UTC
This incident affected: System Messaging.