.BR Registry
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted 14 days ago. Mar 04, 2019 - 14:59 UTC
Investigating
We are currently experiencing intermittent issues connecting to the .BR domain registry. This will impact the ability of users to order, modify, or renew .COM.BR domain registration services. Our Operations team has already reached out to the registry and we will provide more information on this matter as soon as possible.
Posted 15 days ago. Mar 03, 2019 - 17:13 UTC
This incident affected: Domain Services (Other ccTLDs).