.EU Registration issues
Incident Report for OpenSRS
Resolved
We are happy to report that our connection to the .EU registry has recovered. Any previous pending orders may now be processed.
Posted 2 months ago. Apr 11, 2019 - 12:34 UTC
Investigating
Our team is currently investigating an issue with .EU domain registrations.
During this time our Resellers will not be able to complete any registrations and renewals.

We will continue to investigate and provide further updates as they become available.
Posted 2 months ago. Apr 11, 2019 - 12:25 UTC
This incident affected: Domain Services (Core ccTLDs).