Comodo Unscheduled Maintenance
Incident Report for OpenSRS
Resolved
The unscheduled maintenance has been completed.

Thank you for your patience regarding this matter.
Posted 2 months ago. May 15, 2017 - 13:29 UTC
Investigating
The Certificate Authority COMODO is currently performing unscheduled maintenance to restore their system and fix the issue with their database. All SSL management options are affected, with certificate activation and reissue resulting in errors. The maintenance will not affect existing, new, pending or issued SSLs in any way. Expected maintenance window: 2 hours.
Posted 2 months ago. May 15, 2017 - 07:20 UTC
This incident affected: SSL.