.ME Registry Orders
Incident Report for OpenSRS
Resolved
We have been able to resolve the order processing issues with the registry and orders can now be processed normally.
Posted 3 months ago. Jan 28, 2019 - 10:18 UTC
Investigating
We are currently unable to process registrations, transfers or renewals with the .ME registry. We have engaged the registry to resolve the issue.
Posted 3 months ago. Jan 28, 2019 - 09:37 UTC
This incident affected: Domain Services (Other ccTLDs).