Hosted Email
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 14:59 UTC
Investigating
This is a test notification, please ignore
Posted Jul 09, 2020 - 14:56 UTC
This incident affected: Hosted Email (Cluster A).