.DK Registry Connections
Incident Report for OpenSRS
Resolved
Please see our GDPR Implementation list.
Posted 5 months ago. May 29, 2018 - 14:50 UTC
Investigating
We are currently experiencing connection issues with the .DK registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .DK domains. Existing domains will continue to resolve normally.
Posted 5 months ago. May 28, 2018 - 20:25 UTC
This incident affected: Domain Services (Other ccTLDs).