.IT Registry Connection
Incident Report for OpenSRS
Resolved
The Registry confirmed a hardware failure at their end as the cause of the outage, this has since been resolved.

Start Time: 14:14 UTC
End Time: 14:50 UTC

Duration: 36 minutes
Posted Feb 01, 2023 - 17:09 UTC
Update
We are currently having connection issues with the .IT registry. The registry might be experiencing a temporary outage or undergoing maintenance. Our engineering team is investigating and will update as soon as we hear back from the registry.

This affects registrations, renewals, and management of .IT domains. Existing domains will continue to resolve normally.

For a list of affected TLDs, please see: http://opensrs.help/chart
Posted Feb 01, 2023 - 15:05 UTC
Investigating
We are currently investigating this issue.
Posted Feb 01, 2023 - 14:57 UTC
This incident affected: Domain Services (Core ccTLDs).