Trustwave SSL order issue
Incident Report for OpenSRS
Resolved
We should be all set now and are reviewing what happened. Thanks for bearing with us.
Posted Feb 21, 2020 - 02:06 UTC
Monitoring
We can confirm that the issue has been resolved though we are still waiting for the confirmation from the Trustwave team regarding the root cause of the issue. We will add the details of the resolution in a follow up when we've been informed.
Posted Feb 21, 2020 - 00:22 UTC
Update
We are currently awaiting a response from Trustwave regarding this matter.

Updates will be provided as soon as possible
Posted Feb 20, 2020 - 18:46 UTC
Identified
After some investigation, the Operations team found out that trustwave's SSL cert has expired.

We have reached out to trustwave to rectify this issue as soon as possible.

Next update: 6:00pm UTC
Posted Feb 20, 2020 - 17:18 UTC
Investigating
We are currently experiencing an issue with our Trustwave SSL ordering process. Our operations team is investigating.

Client Impact: Transactions for Trustwave orders will be unsuccessful

Next Update at: 5:00pm UTC
Posted Feb 20, 2020 - 16:31 UTC
This incident affected: SSL.