Domain Lookups
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Aug 21, 2019 - 13:06 UTC
Investigating
Our lookup service is partially degraded at this time

This will impact their ability to determine domain availability, as well as submit registration requests.

However, we have no reports from customers managing to replicate the issue at this time.

Next Update: 13:30 UTC
Posted Aug 21, 2019 - 12:34 UTC