Externally Managed TLDs
Incident Report for OpenSRS
Resolved
Our operations team was able to resolve the issue. Registrations and updates will need to be resubmitted if they failed during this time.
Posted 20 days ago. Sep 28, 2018 - 11:25 UTC
Investigating
Users may experience issues when processing registrations and updates for some externally managed TLDs. Our Operations team is investigating the issue.

For a list of all affected TLDs see:
https://help.opensrs.com/hc/en-us/articles/206391417-Externally-managed-TLDs
Posted 20 days ago. Sep 28, 2018 - 11:00 UTC
This incident affected: Domain Services (Core ccTLDs, Other gTLDs, Other ccTLDs).