.RO Registry Connections
Incident Report for OpenSRS
Resolved
This issue is now resolved and .RO registry connections are stable again
Posted Feb 17, 2020 - 13:22 UTC
Investigating
We are currently having intermittent connection issues with the .RO registry. Our operations team is investigating and will update as soon as we hear back from the registry.

This affects registrations, renewals, and management of .RO domains. Existing domains will continue to resolve normally.

For a list of affected TLDs, please see: http://opensrs.help/chart
Posted Feb 17, 2020 - 10:38 UTC
This incident affected: Domain Services (Other ccTLDs).