Registrar Mail Delays
Incident Report for OpenSRS
Resolved
We are happy to report that the registrar mail delays have been resolved. You will now see messages received in real time, these would be ICANN trade, registrant verification, and other system messages.
Posted May 25, 2018 - 16:27 UTC
Monitoring
We are experiencing message sending delays on the registrar mail system used to relay ICANN trade, registrant verification, and other system messages. Some messages sent may be delayed.
Posted May 25, 2018 - 10:12 UTC
This incident affected: System Messaging.