SRS Domains
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted May 26, 2018 - 22:36 UTC
Monitoring
Domain services (orders+updates) may experience irregular or degraded performance

The status will change with future developments
Posted May 26, 2018 - 22:21 UTC
This incident affected: Domain Services (Core gTLDs, Core ccTLDs, Other gTLDs, Other ccTLDs, Premium Names).