nl and .amsterdam Registry Connections
Incident Report for OpenSRS
Resolved
Thank you for your patience. Connections have been restored. No further impact is expected.
Posted Aug 20, 2019 - 06:08 UTC
Investigating
We are currently experiencing connection issues with .nl and .amsterdam. Our operations team is investigating the issue.

Both TLDs are still down after the registry's maintenance window. They have likely extended their maintenance We've reached out to them to confirm/investigate..

This affects registrations, renewals, and management of .nl and .amsterdam domains. Existing domains will continue to resolve normally.
Posted Aug 20, 2019 - 05:53 UTC
This incident affected: Domain Services (Other ccTLDs).