Comodo SSL Certificates
Incident Report for OpenSRS
Resolved
Comodo has now resolved the intermittent timeout issues they were having so we're happy to report that full functionality has now been restored for ordering new Comodo SSL certificates and managing pending orders through our platform.
Posted 12 days ago. Oct 07, 2018 - 00:01 UTC
Identified
Comodo has confirmed they are experiencing intermittent issues on their end which are causing the timeouts and errors with placing new orders and managing existing ones. They indicated they are working on resolving the issue quickly. We will update you as soon as we have more information.
Posted 12 days ago. Oct 06, 2018 - 21:18 UTC
Investigating
We are currently experiencing issues connecting to the ceritifcate authority Comodo. This would impact the placement of new orders and any management of any existing pending orders. We have reached out to Comodo and we expect to have this resolved shortly. This only impacts the ordering of Comodo SSL certificates. All other certificates still function fine. We will provide an update as soon as we have more information.
Posted 12 days ago. Oct 06, 2018 - 16:13 UTC
This incident affected: SSL.