.CA Redemptions - HRS and SRS
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 08, 2019 - 14:01 UTC
Investigating
The .CA Registry is currently experiencing intermittent issues in regards to .ca redemption requests.

A turnaround time of 24 hours has been quoted for a resolution.

We will update this posting as soon as we receive any additional communications from them.
Posted 7 months ago. Feb 07, 2019 - 20:21 UTC
This incident affected: Domain Services (Core ccTLDs).