OpenSRS Phone Support
Incident Report for OpenSRS
Resolved
Our phone system vendor has resolved the issues which may have affected incoming calls to OpenSRS Support. We apologise for the inconvenience.
Posted Oct 16, 2017 - 22:25 UTC
Investigating
Our phone system vendor is experiencing issues which may cause incoming calls to OpenSRS support to fail. We will update this status once there is more information.
Posted Oct 16, 2017 - 21:13 UTC
This incident affected: Reseller Support.