Domain Verification
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted May 28, 2018 - 22:35 UTC
Update
Our team continues to work on the problem and will provide more data when it becomes available.
Posted May 28, 2018 - 14:35 UTC
Investigating
Domain Verification for both Changes of Registrant and new Domain Registrations are currently degraded.

We will provide more information when it is available.
Posted May 26, 2018 - 00:07 UTC
This incident affected: System Messaging.