.BE Registry Connections
Incident Report for OpenSRS
Resolved
Connections to the .BE registry has been restored. Services are functioning as they should.
Posted Jun 20, 2019 - 11:25 UTC
Identified
The registry has provided additional information regarding the problem. Our operations team is now working to resolve the issue.
Posted Jun 20, 2019 - 10:45 UTC
Investigating
We are currently experiencing connection issues with the .BE registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .BE domains. Existing domains will continue to resolve normally.
Posted Jun 20, 2019 - 07:08 UTC
This incident affected: Domain Services (Other ccTLDs).