HostedEmail A & B - Cannot email to other Hosted Email Customers
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Nov 09, 2019 - 20:36 UTC
Investigating
A small subset of users may experience technical difficulties emailing other hosted email customers.

Our team is currently investigating the issue.

Next update: 21:00UTC
Posted Nov 09, 2019 - 15:57 UTC
This incident affected: Hosted Email (Cluster A, Cluster B).