Phone System Issue
Incident Report for OpenSRS
Resolved
Our phone system issue has been resolved.
Posted Sep 20, 2021 - 15:26 UTC
Investigating
We are currently experiencing an issue with our phone system. If you require immediate assistance please use our online chat at https://opensrs.com/
Posted Sep 20, 2021 - 15:03 UTC
This incident affected: Reseller Support.