.MUSEUM Registry
Incident Report for OpenSRS
Resolved
This registry maintenance has been completed.
Posted Mar 11, 2021 - 10:53 UTC
Update
The current connectivity issue preventing .MUSEUM domain registrations, renewals, transfer submissions, or updates was found to be caused by a scheduled maintenance they are currently performing.

Start Time: 03-11-2021 07:00:00 UTC
End Time: 03-11-2021 09:00:00 UTC
Posted Mar 11, 2021 - 08:51 UTC
Update
We are currently experiencing connectivity issues with the .museum registry that will prevent Whois Checks and Domain Purchase, Renewal and Update Requests, along with submitting new Domain Transfer requests. Existing domains will continue to resolve as usual.

We have reached out to the registry to request information.
Posted Mar 11, 2021 - 08:02 UTC
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Mar 11, 2021 - 07:48 UTC
This incident affected: Domain Services (Other gTLDs).