.PL Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that our connection to the .PL registry has recovered. Any previous pending orders may now be processed.
Posted 2 months ago. Apr 14, 2019 - 09:43 UTC
Investigating
We are currently experiencing connection issues with the .PL registry.
This affects registrations, renewals, and management of .PL domains. Existing domains will continue to resolve normally.
Our operations team will continue to investigate, please note this may be open until business hours resume

Next Update: 2019-04-15 13:00 UTC
Posted 2 months ago. Apr 14, 2019 - 04:00 UTC
This incident affected: Domain Services (Other ccTLDs).