Reseller Phone Support Unavailable
Incident Report for OpenSRS
Resolved
This incident has been resolved. Phone support has been restored.
Posted Feb 13, 2024 - 14:38 UTC
Investigating
We are currently experiencing technical difficulties with our phone service, impacting our ability to receive and make calls.

Our dedicated team is actively working to resolve the issue and restore full phone service functionality as quickly as possible.
In the meantime, we recommend reaching out to us through alternative channels (Chat and Email)

We appreciate your patience as we work to resolve this issue swiftly.
Thank you for your understanding, and we apologize for any inconvenience caused.
Posted Feb 13, 2024 - 13:30 UTC
This incident affected: Reseller Support.