Email - Cluster A
Incident Report for OpenSRS
Resolved
Hosted Email services on Cluster A have recovered.
Posted 22 days ago. Oct 26, 2018 - 11:16 UTC
Investigating
Hosted Email services on Cluster A is currently down. Our operation team is actively working on it, and should be resolved shortly.
Posted 22 days ago. Oct 26, 2018 - 11:13 UTC